Editor for CopiaFacts command files

CopiaEdit [filename]

COPIAEDIT is a simple (Notepad-like) text editor designed for use with Copia command files.  It has a syntax-highlighting feature which shows command keywords in bold font, and also includes integrated help. It supports CFG, USR, UJP, FS, IIF, GCT, MBX, and MCF files.

To display help for a CopiaFacts command, either press F1 with the cursor on the command text, or double-click the bold command. This will open the reference page for the command in COPIAFACTS.CHM.  This help file must be in the same folder as COPIAEDIT.EXE.  A help page which lists all the available commands for the current file type is also available from the help menu.

COPIAEDIT loads files with any supported encoding but always saves CopiaFacts command files with the encoding specified by the $unicode commands in FAXFACTS.CFG. If you edit FAXFACTS.CFG and change its own encoding, it will be saved with the new encoding.  The menus and title bar display the encoding.

For files with extensions other than CopiaFacts command files and INI files, the CP_COPIAEDIT configuration file variable allows you to specify automatic encoding detection parameters, which can then be enabled, for loading non-command files, from the Options menu.  Such files can also be saved with non-standard encodings: an analysis of the text will offer available supported encodings, if any, on the Edit menu. The new encoding is then applied when the file is saved.

COPIAEDIT also handles INI files (but without the 'help' function) and can in fact be used to edit any text file (without the syntax-highlighting).  There is a special option to find and open COPIAFACTS.INI which avoids the need to track down the path to this file.

COPIAEDIT also includes undo/redo and printing capability, and can also auto-indent (from the edit menu) conditional commands in a command file.  A backup is made using a file extension with a leading tilde (e.g. .~ext) unless this is suppressed from the Options menu.

If you highlight a filename in the editor and right-click it, then if the file can be found a pop-up menu line will allow you to view the file.  Most common file extensions are supported, and for files such as PDF or DOC an appropriate application must be registered to process the view.  Filenames without a path element are searched for in the appropriate locations.

In Windows Vista and Windows 7, the appropriate folders for opening and saving files are automatically inserted at the top of the 'favorites list', but you may have to scroll up to see it. This example shows the Save As dialog for FS files:

When editing an infobox (IIF) file, if the first command is $authenticate, a password will be requested.  For more information on authentication, see Encrypted Variables.